Problem with Configuration Helper


I’m having a problem when setting content, with the extension configuration service, on the front-end of my extension in which the helper method isn’t updating anything. I may be missing something simple but 3 days and multiple developers haven’t been able to help.

This is the entire script:
EDIT: May as well give the HTML attached too:

The reason I know it’s not updating is that Twitch says “Needs Configuration” during hosted test and line 28 of the script returns a version 1 configuration (which only worked once). I’ve set Required Version to 2 in my extension dashboard.

Lines 27 and 38 are both called in console successfully. No other errors come up.

If anyone could provide insight, that’d be super helpful,

We solved it.

Aside from some funky buisness here and there.

The issue is that the form didn’t have the “preventDefault()” code in place to stop the page reloading. Which was blocking the config set request from completing correctly.

1 Like