Sending /w stopped working (JS/websocket)


I have an interface built in javascript using websockets to communicate with twitch.

socket.send(‘CAP REQ’);
socket.send('PASS ’ + mypass);
socket.send('NICK ’ + mynick);
socket.send(‘JOIN #’ + channelname);

sending whisper:
socket.send(‘PRIVMSG #channelname : /w ttdbot test’);

I was always been able to successfully send whispers, but today it suddenly stopped working.
I’m still able to send messages to the chat. The issue is when I try to send a whisper, it is now displayed in the chat instead of actually sending it privately.

e.g., the following is displayed in the channel’s chat: ‘/w ttdbot test’

I think it may be something “wrong” with Twitch, because I didn’t touch the code :confused:
Does anyone have any idea what might be causing this issue?

thanks in advance!


socket.send(‘PRIVMSG #channelname : .w ttdbot test’);

Instead. I’ve always used the . version of commands that are “non standard” IRC commands and I’ve had no whisper outage here

1 Like

Hi @BarryCarlyon, thanks for the quick answer.

I tried your suggestion, but the same thing happened :confused:


You seem to have a leading space in the message?

PRIVMSG #channel : .w

is not the same as

PRIVMSG #channel :.w
1 Like

nice, it worked!

somehow it was working with the blank space. Removing it solved the issue.

thanks for the help @BarryCarlyon @3ventic

I’ll take things I didn’t spot on mobile whilst walk to work for 100 please ken

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.