[Solved] HTTP 401 when Fetching Configuration

I have an issue with the Linux dev rig that has been preventing me from using it since I updated to version 1.2.2.
I’ve been getting many “authentication failed” messages when I try to use the rig. It happens when I fetch configuration from the configuration service, when I load the extension views, and even upon loading the extension (I see the messages in the console).

Things I’ve tried:

  • Hard refreshing (Ctrl+Shift+R)
  • Clearing the local storage (localStorage.clear())
  • Reinstalling the rig
  • Logging into a different account
  • Inspecting the network calls; the 401s all seem to have Auth tokens, maybe their signature isn’t valid?

Are other people having this issue? Any other troubleshooting steps?
Thanks for the help :sweat:

I figured out my issue – I was able to enter in a Twitch Client Secret into the Open Project Dialog.

For future reference, you should only enter an extension secret into this box.

In my case, I was unable to use the extension secret from a different account (I was getting an “invalid secret” error). For teams that need to develop on an extension, they must be logged into the same account.