The great big "I'm using WIX/SomeWebsiteMaking Tool and I don't know how to fix my embed" thread

Hey guys.
I have the same issue. I just made a new website, new web host account, and uploaded it. The embed isn’t working.

Here is the website I made:
http://systemsunited.net/

My web host is siteground.com

I added both systemsunited.net and siteground.com as the parents, but I guess I need a more specific syntax.
Any clues on how I would find the exact spelling of the parent I need to add?

First you need your website to be over SSL

Second your code just needs to be

              new Twitch.Embed("twitch-embed", {
                width: 854,
                height: 480,
                channel: "systemsunited",
                // only needed if your site is also embedded on embed.example.com and othersite.example.com
                parent: ["systemsunited.net", "www.systemsunited.net"]
              });

Or omit the parent as the JS Lib will determine if for you. Your original code is correct, you missed the SSL required rule

Thank you so much!
Adding SSL was successful, seems to be working now!

THANK YOU!! A little bit of Wix editor sillyness got in the way as well. Appreciate the help, I am G2G.

THANK YOU!! A little bit of Wix editor sillyness got in the way as well. Appreciate the help, I am G2G.

You’re already light years ahead of me, the new embed system has completely broken the connection on our website and I haven’t been able to get it working again. I continue to get the Whoops! Misconfigured message.

I’ll be following your question because once I get the connection re-established I’ll want to make sure it’s in source quality

Post your website here and we can help

Duuuuuuude I just found that thread and after reading through it realized it was the “filesusr.com” parent tag throwing me off. I used an example you gave to another reader and was able to sort it just a few seconds ago.

Thank you so much for your help

1 Like

Welcome and pardon me moving your posts between threads :slight_smile:

1 Like

ADMIN: Duplicate post of Some problems with the embedded player and quality auto detection

Removed for thread clarity

No worries man, I appreciate your help. I imagine it’s like playing whack-a-mole trying to answer all the questions after a big update like this.

I left your existing post where it is as it’s a seperate issue. And I don’t have an answer. Your post didn’t need cross posting here

This thread deals with getting Embeds functional, your embed is functional.

@BarryCarlyon This thread deals with getting Embeds functional, your embed is functional.

It basically works, but it does not work correctly if the viewers first have to make the quality settings by hand because they believe that the stream really runs in 160p. Around 90% will not do it at all and will leave the stream again before the manual correction.

You’ll need to await a response on your main thread.

I cannot replicate the issue you are having. All of my embed tests resuse the last manual setting or defaults to auto. You might have something going on environmentally on your machine. I don’t know but it needs to be followed up on your existing thread not this thread please.

HI Barry,

Thank you in advance for you help. I’ve tried the previous codes you posted here, but still getting an error. My site is hyperfmi.com, but the page with the feed is https://www.hyperfmi.com/hyperview.

Your help is greatly appreciated.

https://player.twitch.tv/?channel=hyperfmi_viewer&parent=www.hyperfmi.com&parent=hyperfmi.com&parent=www-hyperfmi-com.filesusr.com

Is the correct structure. You had a path instead of jsut the domain name. So copy the same parents to stream b (and chat when you add that)

You Rock!!! Thank you Barry!!!

Sorry, last thing. Is there a way to remove the follow icon / button on the screen, when I’m not streaming?

Not to my knowledge no.

You could instead use code to show/hide different content if the stream is live or not, but you might have problems doing that on Wix

Understood. Thanks again!! You quick response was amazing!