Cannot register a new application

I’m new to the twitch API and am attempting to use it for the first time. When I tried to get a key be registering an application on, I clicked the ‘Create’ button and it did nothing. The details I input were Name: Test, Redirect URL: http://localhost, Category: Application Integration. When I checked my browsers console, I got the error message:

[GraphQL] One or more GraphQL errors were detected on request1HA7A5Q40ZZ43WBDTBRQ0B1MM. CreateOauthApp: service error

I saw someone had a similar issue on this thread, however none of their solutions have worked for me. I’ve tried the following workarounds and nothing has worked:

  1. Switching to Firefox and Edge
  2. Logging out and logging back in
  3. Changing the name randomly (sometimes to random alphanumeric). I read some keywords like “Twitch” are against policy (not that I had any of those to my knowledge)
  4. Registering on a different device (both Firefox and Chrome)
  5. Clearing browser cookies & cache then logging back in

None of these solutions are working and give me the same GraphQL error. I’m kind of stumped. Has anyone had a similar problem?

You have tried using a name that is two or more words as apposed to a single word?

A name should adequately describe the product. Which is generally more than a single word. But I suspect the UI is unhappy about single words.

And creating from screatch currently doesn’t surface the name error correctly.

Well test is probably already taken as a name, reserved, or already in use.

Did you also check for if any ad or script or other kind of blocker is blocking recaptcha from functioning?

1 Like

That was it! I wasn’t aware that duplicate names weren’t permitted. Still a little strange that random strings of characters wouldn’t go through, but maybe they broke some other policy I didn’t know about. I really wish the UI would be clearer about these errors.


it’s filed as an issue - App Creation doesn't surface name errors · Issue #831 · twitchdev/issues · GitHub so just waiting on a fix to be deployed

Thanks bud, I was struggling with the same thing. looks like this has been an issue since at least 2018.