Authentication does not work in WebKit browser last 3 days

Authentication in WebKit browser worked correct last year and stopped to work last 3 days, in the same time it works now successfully in IE and FireFox.

WebKit browser is used by Qt apps.

During authentication in WebKit I see html message {“redirect”: “some url here”}

After a few attempts to login I also see captcha, after entering login info and captcha I see error:
{“message”:“Please complete the CAPTCHA correctly.”,“captcha”:“true”,“errors”:[“Please complete the CAPTCHA correctly.”]}

This error is reproduced all time and not possible to login to Twitch in desktop app using WebKit browser.

I found in google that other users report about the same problem:

Will be this bug fixed?

I investigated a bit more this bug and found next:

  1. Probably Qt WebKit does not load extrenal javascript js file.

And here:
recommends to use require() function instead of < script > tag that can produce an error

  1. And second possible reason of error something like to described here:

Also one note -> I receive in WebKit one javascript console message during loading authentication page: “TypeError: ‘undefined’ is not a function”, lineNumber = 0

Will be this bug fixed? Login to Twitch worked fine in WebKit last months and stopped to work only 3-4 days ago.

Would love to see this fixed ASAP. Currently have two applications that are broken because of this and users can no longer authorize, thus are unable to use these applications.

What are you using for login that stopped working on the Twitch side? Is it when the OAuth page loads and then redirects?

Our program is built on Qt 4.8.6 and for login to Twitch we are using WebKit browser included in official Qt 4.8.6 release.
WebKit browser version it seems ~2.2.4.

Now is avaiable Qt 5.7.0 where WebKit browser was replaced with Chromium browser but we do not want to upgrade our program to use Qt 5.x because it has some bugs on Windows computers. So we continue to use Qt 4.8.6.

Authentication in Qt 4.8.6 WebKit browser worked successfully last months, but stopped to work a few days ago.

  1. We load in WebKit browser next url:{app_client_id}&redirect_uri={redirect_url}&scope=user_read+chat_login

  2. Then we see login form, we fill form with ‘user’ and ‘password’ data, press login and see in browser white page with text:
    {“redirect”: “some url here”}

  3. After a few like attempts to login we see login form with captcha. We fill form with ‘user’ and ‘password’ data and fill captcha, press login and see white page with another text:
    {“message”:“Please complete the CAPTCHA correctly.”,“captcha”:“true”,“errors”:[“Please complete the CAPTCHA correctly.”]}

If enter in login form incorrect ‘user’ and ‘password’ data and press login - message is the same.

  1. Authentication works now successfully in IE11 and FireFox and we receive access_token.
    Authentication worked successfully in WebKit last months, we nothing changed in WebKit work last months and weeks, authentication stopped to work in WebKit a few days ago. In my previous post I wrote about a few articles that I found in Google and where said about WebKit bugs.

In my research for the implicit grant flow authorization, I was seeing this js error in the web inspector tool on page load of the Twitch Log in (…):

TypeError: 'undefined' is not a function (evaluating 'l.bind(this,o,c)')

I understand that the .bind() js function is kind of ‘newish’ that probably wouldn’t be supported in the older webkits. (Confirmed with a new Qt version (5+) that the Twitch login page would per just dandy.)

Today, I just tried authorizing Twitch on a Qt4.8.2 webkit build and it appears to be working again. Something must have changed on Twitch’s end recently for this log in page? Is it working for you now @GamersBoss777 and @DeezjaVu?

Seems to be working properly again.

Login to Twitch is working now correct in WebKit browser. Thank you!

Again the same problem. I´m sorry that page:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.