Cannot Create Project in Dev Rig - No Manifest Created

I was able to create the extension (it shows up in Developer Console), but when I try to create a project for it in the Dev Rig, I can get to step 3 where is seems like it worked, and I click “Get Started”, and it does nothing. If I let it sit for a few minutes the window displays this message: “An error occurred. Please check the Developer Tools console.”

The Developer Tools Console shows this error:

Error: npm failed with exit code 1: npm ERR! code ETIMEDOUT
npm ERR! syscall connect
npm ERR! errno ETIMEDOUT
npm ERR! network request to failed, reason: connect ETIMEDOUT
npm ERR! network This is a problem related to network connectivity.
npm ERR! network In most cases you are behind a proxy or have bad network settings.
npm ERR! network
npm ERR! network If you are behind a proxy, please make sure that the
npm ERR! network ‘proxy’ config is set properly. See: ‘npm help config’

I’ve tried this now on two different networks (and two different computers). Also, even though this error occurs, it does create my folder (using boilerplate template for React) with all my template files, but it does NOT create the manifest file, so I cannot open it in the Rig.

I suppose I could create the manifest file myself by copying another one and making the necessary changes, but still would like to resolve this issue with the Rig.

Your extension does have at least one version?

So if you go to

and hit manage on the extension you get the right and not the left?

You can’t import an extension that has no versions

Yes, it has a version. I had to do that after creating it in the Dev Rig, even with getting the “Sorry this name is taken” error.

Restart the righ and then try to import again.

If it doesn’t work, the rig is optional so can be skipped

My solution was to downgrade my version of NPM/Node. Then reinstall node_modules and it worked.

@Areliven I had the same issue. Which npm/node version did you end up using?

I ended up with NPM version 6.14.15 and Node 14.18.2

‘npm update’ also fixes the issue.