Cannot generate new Client Secret

Hey, two weeks ago I created a new aplication. Everything was working fine. When I was working from a different device, I had to create a new client secret in order to get the app running. I created a new secret because I did not include it in the GitHub repository. When I switched back to the original device I wanted to generate a new secret again. Unfortunatelly, whenever I click on “new secret” and confirm this step, I do not receive the wished client secret. Instead I receive the following console error: "One or more GraphQL errors were detected on request … ResetOAuthSecret: service timeout. I tried this step in the chrome and edge browsers of my PC and in the chrome browser of my mobile phone - without any success. First I thought that it might be a twitch problem, but it has not been working for at least 24h.

I checked three applications and was able to generate a new secret.

One of the applications even had an invalid HTTP Redirect URI and I still got a new secret.

So I couldn’t replicate it.

Looks like you’ve tried a few things so the only thing left to try is to full logout from Twitch and back in.

And to check your Application is of type “confidential”?

Well you never should since a secret, well, should be kept secret

Thanks for your help! It actually was “confidential”.
I gave up on this app, I created a new one and swapped the new client id and secret for the old ones. This way everything is working fine again.
Funnily enough, yesterday I was not able to create a new twitch application at all.