Can't get Twitch CLI to generate a user access token after previously having no issues

twitch token -u -s ‘chat:read chat:edit’

This command was working fine for me. When I use it I still get redirected to localhost:300 with what looks like a success message just saying “feel free to close the browser”.

However where the code used to print out in the console, the console just sits at Opening browser. Press Ctrl+C to cancel…

Not sure what could cause this to stop working all of a sudden. Any help would be cool.

Similar issue has been reported Token generation stuck on opening browser · Issue #151 · twitchdev/twitch-cli · GitHub

Thanks, i saw that and couldn’t get that to work being on Mac. Would the solution be the same?

The “solution” in the GitHub isn’t a recommened one.

Common issues are you have something else occuping the port.

I pointed to the post since the issue has been reported and pending someone in the know to investigmate

the current build (1.1.6) is working fine for me on my mac

So theres something environemntal on your mac that might be screwing. (Another server style script thing sat on the port perhaps)

I have killed all the processes on port 3000 which is the only referenced port i see in the documentation. Is there another port I should look at or a way to just do a general reset?

I used postman to manually make the request and that seemed to work. For some reason only when I make the request using Twitch CLI do I run into this issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.