Can't see the Extension Coordinator Run list in local mode

In the developer-rig docs, in the local mode section there is this quote:
When Local Mode is enabled, each extension view will have a dropdown that enables the developer to choose a response from the "Run List". When a response is selected, clicking the "Trigger" button will send it through the Extension Coordinator and it will pass through Helper to your extension code.

Where exactly is this Extension Coordinator located?

1 Like

is the thing that “manages” extensions and communications.

For local mode it’s built into the dev rig, on live it’s “like” a server that twitch runs to relay messages/control the extension

Thanks Barry, I think i follow you. So, in local mode, using the default dev. rig setup, after running yarn start in the dev. rig repo, the "Run List" mentioned in the above quote will be visible in the interface visible at: ?

Not quite…


After having created a suitable manifest, you can launch the rig in local mode using yarn start -l manifest.json

  1. Runlist data is in developer-rig/runlist/runlist.json for creating/editing the “mock” responses to trigged.


  1. Your “RunList” items are found under the mockresponses:

Fantastic. Thanks for your help. Was just missing the manifest.

For some reason my iframes are set to display: none; unlike yours. any ideas?

Since both the rig and your extension are served using Self Signed certs, right now you have only accepted the cert for the rig. You need to visit the extension’s URL in a separate window/tab to access the cert. That should get it going.

Thanks. Just tried what you suggested. Visited the 4 variants I could think of but still iframes are empty:
https://localhost:8080/ (shows security warning)
https://localhost:8081/ (shows security warning)

Could the issue be those shows security warnings?

[removed wrong information lack of coffee]]

I haven’t yet been able to create an extension in the dashboard, beccause my on-boarding is still being processed.

local mode should still work with out that though, right?

So i’ve tried accepting all 4 variants posted in previous message.
Tried the same in both chrome and firefox.
Also enabled this flag in chrome: chrome://flags/#allow-insecure-localhost

But, still no joy with the iframes :confused:

what are you working on in that screengrab from earlier, btw?



lets try starting the rig, removing the views, stopping the rig, starting the rig, making the views again!

make sure to start using yarn start -l manifest.json where manifest.json is the name of your manifest and retest

You are using yarn host -d <directory>/public -p 8080 to host/run your extension code?

Nothing thats the live version of Sacriel’s Extension. Just the only thing i have “rig testable” right now as I don’t usually use the rig myself :smiley:


see also this issue:

You need to include <script src=""></script> in your ext html file

Not quite running yarn start -l manifest.json. Am instead running: yarn start -l ../my-extension/manifest.json because the manifest is in my extension folder. Could this cause problems?

Yes am running yarn host -d ../my-extension/public -p 8080.

The content of the iframe is there, if i manually remove the display: hidden; inline css using the chrome element inspector.

Here’s my manifest. I tried generating it using yarn create-manifest, but it didn’t seem to actually create a file. It only echoed a bunch of json to the terminal (which i then copy and pasted and manually made the manifest file.)

I’m running the hello-world example, but double checked and <script src=""></script> is defo included on each page.

So do you not develop extensions ? or have you just got another way to build them?

I develop extensions. I have three private/single streamers extensions and one Public everyone extension

Yes, there was a time before the rig existed and I prefer that method myself


This is weird I’m out of ideas. I wonder if it’s a new hiccup/bug/issue with the rig? Maybe time to open a issue on

Some times weird issues in the rig just magically resolve themseleves…

You can try some of the trouble shooting steps:

Try the Clear your browser cache and local storage, restart the Developer Rig, and cross your fingers. To delete its local storage, use your browser's developer tools to do so then refresh your browser first

OK, thanks for helping my man! Appreciate it. Give me a shout if you ever need a beta tester or something for one of your extensions.
Here’s a link to the issue:

@BarryCarlyon turns out that I was just missing the -l flag!
E.g. yarn host -d <path_to_hello_world>/public -l

1 Like