Developer rig installation alongside vagrant

I use vagrant environments for most things, but have never had to use Node before until now with this developer rig install.

Anyways, after running the install, on just plain old mac outside of vagrant, I noticed I wasn’t able to view the Hello, World. I also noticed that my /etc/hosts wasn’t edited as it said it would be. I added the line into hosts and still nothing is happening. I think because vagrant uses localhost.

Any way to change Node to look at some other port so I can point my host at it, or is something else breaking it?

Since you are running it inside Vagrant, It probably edited Vagrants /etc/hosts instead of the mac’s

You can’t change the port, as the Dev Rig uses Twitch Auth. and the Auth uses a specific redirect URL that you can’t change.

Basically you are making it more complicated by running it inside vagrant as it’s not really “designed” for that.

You’d have to forward/open the port externally on vagrant and access the rig via that port. And your /etc/hosts on the mac (not in vagrant) would need a rule pointing the line to the vagrant IP instead of

So on the mac instead of

it would be

Or whatever vagrant raised up on…

I’m not running the developer rig in Vagrant. I’m just assuming that since I use vagrant for my other projects it has messed with the developer rig install since my localhost is tied to something else.

I ran “run” on the mac and realized it did not install yarn, so I ran “configure”, but I’m still unable to pull it up. Even when I change my hosts to

Any ideas?

EDIT:: Disregard, fixed it by running “run” again after clearing from my hosts.

Glad you are up and running!