EBS Hosted Test- URL added to Allowlist still throwing CSP error

Hi, My extension connects to Firebase Functions http endpoint to sign the JWT. I’ve just moved my extension to hosted test and ran into this CSP error:

main.js:134 Refused to connect to '---endpoint-url---/question/' because it violates the following Content Security Policy directive: "connect-src 'self' https://yurx904w9cw11bh51fg62hbt7zp7fx.ext-twitch.tv https://api.twitch.tv wss://pubsub-edge.twitch.tv https://*.google-analytics.com https://stats.g.doubleclick.net https://www.googletagmanager.com".

I went back to local test to add the Firebase domain. Saved and moved back to hosted test. I’m still getting the same error.

Not sure what to try next.
Hope someone can help!

99.9% of the time this is caching in your browser.
The browser is being overly aggressive in it’s caching

So defeat the cache.

Hi No luck! I always clear cache, I tried logging in again and deleted the application cookies too. I tried incognito window but Twitch wouldn’t log me in.
Thanks for you help

When I last had this

It was cache.
But I also kicked it by going to local test and back to hosted test

And checked I dumped the cache of the extensions sub domain not the cache of twitch

As extensions in hosted/release are on https://CLIENTID.ext-twitch.tv which is a different cache group to twitch.tv

OK tried all those and the solution was deleting the https://CLIENTID.ext-twitch.tv cookie as you mentioned. It logged me out in the process but its working now.
Thanks for your help!