Embedding is not working


i have virtual machine as my server and i was developing on it. now embedding is not working. i tried to make my connection ssl(with broken cert) but i cant put ip as parent it tells me that domain is incorrect. I tried to set host as dummy domain and bind my vm ip and im getting refused from the player

could you please provide proper process of making it work?
i have my network ip and i would like to make it work with parent and not create certs and other fluff i dont need on my local setup

Thanks in advance

You don’t need certs for locahost

If you are not on localhost you will need certs

You’ll have some fun with IP addresses as it’s just not supported really, throw a “fake/test domain” at it using /etc/hosts might help?

is the TLDR on that.

See also

Yeah i saw those. i had issue on the site and needed to add parent not that long ago
Is there any way of making ip to work as parent or it’s only domain?
also how do you verify validity of the domain?

Just domain. Since it’s goes https://domain.dom or http://localhost:* as the accepted things in the response header. (based on the inputted parent) and ip’s are not accepted.

Edit: Did a little testing to confirm. Twitch expects a domain name, or any other IP is not accepted (I tried a couple in the 192.168.x.x range)

i see thanks for verifying.
Most likely i’ll need to use local proxy like fiddler or similar to reroute calls and make them “localhost” to avoid creating complicated setups just for development

Thank you for your time

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.