Failed to get user details from Twitch.TV

Strangely, I get this error from time to time from the ruby gem with OAuthing. Does this happen to anyone else?

The exact error is:  Omniauth::Twitchtv::TwitchtvError: Failed to get user details from Twitch.TV

1 Like

I believe there’s an ongoing issue where users sometimes authenticate your application, and you’re given an invalid authentication code to fetch with. The error rate is super low, and I’m not sure whether or not Twitch has given any thought as to what causes it. Having the user reauthenticate resolves it.

This is happening much more than usual today. Anyone from Twitch with some insight?

I added some extra debug:
401 - {“error”:“Unauthorized”,“status”:401,“message”:“Token invalid or missing required scope”}

I’m able to log in fine. Looking at the requests in bugsnag, this is what I’m seeing:

url hexidecimal]&scope=user_read+user_follows_edit+user_subscriptions&state=[some hexidecimal]

referer[correct client id]&[some hexidecimal]&scope=user_read+user_follows_edit+user_subscriptions

Given that my auth works AND I’m passing the scope through, I’m confused as to what the error message could mean. Any ideas?

This is now happening VERY often. Several times per minute for us.

I’m seeing this too, much more often today then over the past week or so.

Was fine for a few (~12) hours but now it’s throwing this error again. Anyone from Twitch read this forum?

Added issue with the API -

Still no reply.

Happening less now. Once an hour or so.

This error happens when trying to get the user details from Twitch. I’ve changed our app to retry five times after waits of 1-5 seconds. So far it’s done 123 retries since it was deployed ~12 hours ago. It’s a lame solution but it’s better than exploding at the user. We’re still getting a few timeouts/errors from the API calls but it’s better than nothing.

Happening over 100 times a day at the moment. Please help!

We’ve been making changes over the last week to attempt to address this issue, but none of them have completely solved the issue. We pushed a change today that we think might be the final fix, but then the site became unstable so we’re still unsure if it’s been fully addressed.

If you’re still experiencing this tomorrow, please let us know.

I’ve actually been getting a similar problem but even weirder. Yesterday morning I was doing a giveaway and it said follow to their twitch so I clicked it but it keeps saying Twitchtv expired please try again. I’m already logged in but it keeps saying that what do I do!!!

Still happening many times per day.

After several testing this past hour, I found a solution for my case. It was telling me that my TwitchTv was expired.
In Gleam, there is this phrase in the middle of the page: ** Entering as UserName (Social Media apps…) **.
So I put my cursor over the twitch logo to see the username. And guess what, It was a different one. Gleam was ‘’ linked ‘’ with my account A, but twitch was logged in with my account B. that’s it for me now. I just had to relogin with my account A on twitch, then it worked like a charm since this morning.

Sorry for poor English, I usally speak in French.

@Ala_Drine Oh my god, I don’t know if you are going to read this but you just saved me a whole lot of time with your answer! Was having the same problem and your solution was so easy and quick!! Thanks so much!