Failure to add topic after authenticating to pubsub

Hello, I’m trying to listen for channel redeems. Though when I do it just returns an empty error. I should have authed for the right scopes.

I could understand a possible error because I my self am not an affiliate so my account doesn’t have the ability for channel points. If that is the case is there by chance a sandbox of sorts where I can play with that? I’m currently trying to design something around channel points.

Upon further testing it doesn’t seem to be the case (possibly). When I tried to listen to the user-moderation-notifications topic I received the same error message. Am I doing something wrong? I’m currently using the sample code found here for testing -

example auth token: 123
my user id: 253634072
redirected url: http://localhost:8000/#access_token=123&scope=chat%3Aread+channel%3Aread%3Aredemptions&state=_&token_type=bearer

INFO: Socket Opened
SENT: {"type":"PING"}
RECV: {"type":"PONG"}
SENT: {"type":"LISTEN","nonce":"LPD2xkos0Ey0Em7","data":{"topics":["channel-points-channel-v1.253634072"],"auth_token":"123"}}
RECV: {"type":"RESPONSE","error":"","nonce":"LPD2xkos0Ey0Em7"}

INFO: Socket Opened
SENT: {"type":"PING"}
RECV: {"type":"PONG"}
SENT: {"type":"LISTEN","nonce":"Swt3hEdg7UUP7UL","data":{"topics":["user-moderation-notifications.253634072"],"auth_token":"123"}}
RECV: {"type":"RESPONSE","error":"","nonce":"Swt3hEdg7UUP7UL"}

Empty error = you subscribed correctly - there was no error

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.