Get Streams API for the current user returns blank object

We recently migrated our code to Helix following this doc: Reference | Twitch Developers
But based on our test, we only get the ff. in the response:
Our call looks like the ff.
Method: GET
Authorization: Bearer
Content-Type: application/x-www-form-urlencoded

Is this a bug or expected behavior? If a bug, what can we do to fix it? If expected behavior, what can we do to get correct stream info of current authenticated user from our Windows app?

You don’t need this header.

This suggests the user you tried to look up is not currently live.

You only get data if the streamer is live

For example, using the twitchCLI

I am not live

barrycarlyon@Robyn ~ % twitch api get 'streams?user_login=barrycarlyon'
  "data": [],
  "pagination": {
    "cursor": ""

CohhCarnage is live

barrycarlyon@Robyn ~ % twitch api get 'streams?user_login=cohhcarnage'
  "data": [
      "game_id": "512953",
      "game_name": "Elden Ring",
      "id": "39538994809",
      "is_mature": false,
      "language": "en",
      "started_at": "2022-03-08T12:41:17Z",
      "tag_ids": [
      "thumbnail_url": "{width}x{height}.jpg",
      "title": "Elden Ring (Deaths: 7)! - !HFWUnboxing - - !PC - #EpicPartner Creator Code: COHH",
      "type": "live",
      "user_id": "26610234",
      "user_login": "cohhcarnage",
      "user_name": "CohhCarnage",
      "viewer_count": 13566
  "pagination": {
    "cursor": ""

This suggests the user you tried to look up is not currently live.

I was live for over an hour when I reported and the response never changed.

I’m trying twitchCLI but my client secret is not being recognized - the same one that I use in our app.

You did do a

twitch configure

Ensuring you copy/pasted clientID/secret in full?


twitch token

To generate a token to use and confirm it’s working?

Define not recognised, what is the error returned?

Yes, but it returned 403 ‘invalid client secret’. Coordinating w/ our ops in case they changed/reset the secret. BRB.

Made twitchCLI work, so moving on w/ viewer count test and I still see that the response is still blank.

Sounds like an occurance of GitHub 11

Is there a fix from Twitch’s end or a workaround we can implement on our side? So far, we have at least 4 known cases.

From various testing/reports the stream is reported to EventSub.

But you won’t be able to track viewer counts.

It seems “the black box” discounts/ignores streams based on criteria that we don’t know or it’s a flat out bug.

Either way if you are tracking a “true” stream rather than a “test” stream the problem should go away.