Introducing an AWS Credits Program for Extension Development

Hey, friends!

We’ve been talking to developers from around the world about Twitch Extensions, and one thing we’ve heard quite consistently is that you’re excited to get building, but unsure of how to deploy an Extension that can handle ‘Twitch scale’ without the risk of breaking either your servers or the bank. It is for this reason that we’re quite pleased to launch the Twitch Extensions on AWS credits program.

“What does this program do?”, you ask. Well, it’s your opportunity to submit your idea for an Extension, and—if selected—begin developing and testing your proof-of-concept with the help of AWS Promotional Credits. We’re looking forward to seeing what you come up with!

Please visit for more details, or to apply.


Oh, and we wrote a little more about the program over on our blog, so feel free to check that out too!

After submitting the application I am receiving “Forbidden You do not have access to perform that action.” I also have an AWS account, Twitch account, and have completed the Extensions onboarding. Please help!

Oh no! I’m sorry to hear that. I don’t currently see any issues internally, but I’ll check with the team. I’ll also update this thread if we identify any widespread problems.

Perhaps in the mean time try once more if you haven’t already?

I tried another 3 times and unfortunately, I am receiving the same error message.20 PM

I’m getting the same error. I’ve tried disconnecting/reconnecting the Twitch Developer Portal connection a few times and still the same thing.

This is the url I get when I submit and it shows the error -

@GamerBilly @coolant
Try to :
disconnect ->
disconnect “Twitch Developer Portal” ->
reconnect ->

Tried tdisconnecting/reconnecting with no luck.

Two things that I additionally noticed.

  1. It doesn’t have my username/avatar on the top right like the other pages when I submit the form (see screenshot).

  1. My and usernames are different which is odd. They are linked, but maybe that has something to do with it?

It looks to be fixed, it decided to work today for me! Give it another go.

Hey friends!

It looks like the issue was with the permissions on the resulting success page of the application process.
If you saw this error, no worries; your application was still received!

It’s all fixed now, apologies and thank you for your patience!

— Amorelandra

sorry to mess up but this aws event is still available? I would like to change heroku for some aws features