isSubscriptionStatusAvailable returning false

I know this may seem like a none issue but bare with me while i describe the problem.

  1. Around a month ago I released, installed and activated Viewer Information (18mdz6bwjda5he7bfsae6h91lgxgdw) on my channel.
  2. At that point an auth box popped asking for permission to subscriber information
  3. Yesterday during my stream a viewer pointed out the Sub info and Sub leaderboard was no longer showing on the extension
  4. After a quick debug we found that isSubscriptionStatusAvailable was false

Nothing changed:

  1. I have not released a new version of the extension
  2. I did not uninstall and re-install the extension (or actiavte and deactiavte)
  3. Everything was as it was on Sunday (5th May) when it was previously working.

I tried:
Deactivating, uninstalling, reinstalling and reactivating the extension however I am still getting the false.

There was no auth box displayed, still got false from isSubscriptionStatusAvailable

I tried:
Removing the connection to the extension in the connections section of settings, then deactivate, uninstall, reinstall, reactivate.

Got the auth box for accessing sub info, still got false from isSubscriptionStatusAvailable

I’m now currently stuck as to why this is still coming back as false.

Thanks in advance, Me!

Greetings Morrell!

Yesterday around noon PDT we pushed out changes to improve the way the Subs in Extensions authentication is performed. Due to an issue with this deployment the isSubscriptionStatusAvailable field was incorrectly populated with a value of “false” regardless of your extension’s ability to use these features. This was fixed in a deployment today and this should no longer be occurring.

We sincerely apologize for the outage of these features and are shoring up our testing to ensure that we catch issues like this one before they are ever released.

Thank you for your continued support as a developer and keep building awesome extensions!

Software Engineer, Extensions

@Miri Thanks for this, I can confirm this is now working

Also “Congrats of 1st post”

1 Like