My extension sometimes doesn't work on Dev Rig

My dev rig sometimes stops works, It just shows an empty panel (it doesn’t reach the React code). I don’t see any error but I understand that the files are not being served properly.

I already had this problem and I fixed it but I am not sure how I did it and I have it again :S

I think that it’s happening when I go from hosted test to local test (but I am not sure).

Someone has experienced something like this?

If you change the extension configuration in the developer dashboard, you need to till the Rig to reload the manifest. Which on the browser based version is on the last tab iirc. And on the beta native rig on the Project Details.

Or a rig restart should fix it

I have all updated and still not working

The extension is configured properly (It usually works with this)

I have restarted all; laptop, rig dev with yarn start and rig dev with the run file. I have even delete the old project and created a new one. Still I get a white panel.

1 Like

Then you need to check the chrome inspector for errors.

It sounds like you may have packaged your files incorrectly, and you are getting a 404

You need to package the files in your folder, not the folder itself


In addition, make sure you are using relative URL’s to your assets/js/css

current status:

  • Local test doesn’t work even creating a new version
  • Hosted test works properly
  • Chrome console shows this errors, but it was working with the same errors previously
  • Rig terminal shows this one

Chrome console messages are irrelevant here

Rig Terminal shows that server.js didn’t start.

As port 8000 is in use.

This might conflict with SLOBS if you are a SLOBS user, or Skype (though Skype is 80 and 8080 iirc usually)

I have found a workaround for my problem.

I need to open directly the URL in a browser and accept the “This connection is no private” warning. After that, the rig is working properly.

That would be the self signed cert not being accepted or installed into your OS

And is not related to the screenshot/error you posted above…

Yes, I know it. But I wasn’t receiving any error for the cert problem so I posted some errors that I had.
It looks like I need to accept it twice each time I restart the rig dev.

Hey thanks for the solution. Thought the link does not work for me. It says This site can’t be reached’s server IP address could not be found.

I ran yarn start and the React component works fine on browser https://localhost:8080/panel.html. Then I found on DevRig I should not click Run Front End, the it would show by itself. Not sure whether it is the correct way to run Boilerplate.

By the way I changed according to this post:

Did you add to your hosts file? If you don’t want to do this you can use localhost instead just change your manifest

Yeah I did. In it looks like this:

openssl req \
  -newkey rsa:4096 \
  -days 1001 \
  -nodes \
  -x509 \
  -subj "/C=US/ST=California/L=San Francisco/O=LULZCorp/OU=web/CN=localhost" \
  -extensions SAN \
  -config <( cat $( [[ "Darwin" = "$(uname -s)" ]]  && echo /System/Library/OpenSSL/openssl.cnf || echo /etc/ssl/openssl.cnf  ) \
    <(printf "[SAN]\nsubjectAltName=DNS:localhost,")) \
  -keyout "${DIR}/${NAME}.key" \
  -out "${DIR}/${NAME}.crt"