"No client id specified" but I am passing a client_id


Where should I be troubleshooting if my oAuth2 URL contains “client_id=mynewclientidcreatedjusttoday” and despite the value being correct I get 400 error returned? I tried an old and new client_id with the correctly paired secret. Should I be ignoring the “No client id specified” part and focusing on Bad Request or can the message part be trusted to point me in the right direction?

{“error”:“Bad Request”,“status”:400,“message”:“No client id specified”}

Here is an image to add some proof (client ID partially hidden but it is correct)

Thanks you for your time. I need to sleep and look forward to waking to discover I’m missing something obvious. That is what happens 99% of the time huh!

If the client ID is invalid for some reason, you’ll get “No client id specified.” Make sure the full client ID is passed.

1 Like

The full client_id is passed along with scope and state.



You can close this I solved the problem thanks.

Please share the solution so the thread can be useful for others who come across it in the future. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.