Problem with the webhooks subscriptions, It's work in http but not in https


I would like to subscribe to the webhook in the topic: Subscription Events, So I need an https address to receive the hub.challenge, except that twitch does not make any GET request to my callback address, however after the request POST at I receive a code 202, I tried with an other topic: User Follows, which does not require a https callback, and here it’s work : Twitch sends me a GET request (in http not in https) , I don’t understand why… Of course when I go to my https callback address everything works!

If it can be useful the domain name I use was set up less than 48h ago maybe it does, but really I don’t think it affects SSL standards

Here is my code for my Node JS Express WebServer

I hope someonewill can help me ^^
Thank you,
Have Great Day !

You have to be using a real SSL Certification

Since this is not working it suggests there is a issue with your SSL Cert or it is a self signed cert.

Personally I use NGINX to SSL Terminate and LetsEncrtpt for certificate providing

I got my key and my certificate thanks to certBot, it doesn’t work?
I admit that I don’t know much about ssl standards, what call you a real ssl certificate ? ^^

Thank you for your response !

Cerbot is letsencrypt so sounds like you have a good/valid cert.

Have you tried your own SSL routes to make sure they work in the browser?

oh okey,
yes i had, even with postman, all is working for me the page send me the hub.challenge when I specify one!


I don’t see anything obviously wrong at this point.

Check your server access/error logs to see if Twitch actually made the request. And the request didn’t make it to your node server

Since you are not declaring anything you might be declaring a incompatible set of SSL Ciphers, which the browser accepts but Twitch doesn’t

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.