[Resolved] Helix API / subscriptions KO

Hi !

Since few hours I cannot get my subscriptions list.

$ curl -H 'Authorization: Bearer xxxxxxxx' -X GET 'https://api.twitch.tv/helix/subscriptions?broadcaster_id=145328278'
{"error":"Not Found","status":404,"message":"This API does not exist"}

if i put a wrong url ( “subscribers” instead of “subscriptions” )

$ curl -H 'Authorization: Bearer xxxx' -X GET 'https://api.twitch.tv/helix/subscribers?broadcaster_id=145328278'
{"error":"Not Found","status":404,"message":""}

The message is different.

If the auth token is false, the return i have is :
{"error":"Unauthorized","status":401,"message":"Must provide a valid Client-ID or OAuth token"}

It worked since many time.
Do you have clue to resolve this issue ?

It’s working fine here right now.

Is this still occuring for you?

It is still occuring for me.
I tried it on my desk and 4 differents server, its the same.
( and it worked since many time … )

Do you have some clue to know what can give me the message :
This API does not exist

Because i dont have this message if a call a fake endpoints

Hmm I can’t see anything wrong here.

Course I can’t check your subscribers as I’m not authorised.

How long ago did you become an affiliate?

It might be something with your desk/four servers doing something weird with routing or injecting stuff into the request.

Did you try a server in a different region?

It’s fine for me from Canada and UK

It’s “only” a token with “channel:read:subscriptions” scope, so i can share it (and revoke it later) no sensitive data share with this.

I barely have no subscriber on this account (but i have one for sure !)

I have the same issue with the streamer i’m working for. (more than 1K sub for this streamer)

Information about the token :

$ curl -H 'Accept: application/vnd.twitchtv.v5+json' \
-H 'Authorization: OAuth REMOVED' \
-X GET 'https://api.twitch.tv/kraken'

Call :

curl -H 'Authorization: Bearer REMOVED' -X GET "https://api.twitch.tv/helix/subscriptions?broadcaster_id=145328278"
{"error":"Not Found","status":404,"message":"This API does not exist"}

You have just intentionally violated the developer agreement you agreed to when you created a ClientID.

You should NEVER publicly post Client Secrets or oAuth tokens…

Edit: passed thread up the chain for additional investigation

Ok, i explained why i did and why it was not a real issue te me to share it.
(scope limited and not sensitive data behind this call)

But i’ll not do it again !
Sorry for the inconvenience :pray:t2:

About the initial subject, it seems to occurred in the same time as :

Did you try just making a new oAuth token?

The one removed was a new token created

I created a new token with scope for new api and api v5.

In the new Twitch API:
`curl -H "Authorization: Bearer <access token>" https://api.twitch.tv/helix/`

In Twitch API v5:
`curl -H "Authorization: OAuth <access token>" https://api.twitch.tv/kraken/`

Am I supposed to get a result with those calls ?

The call on APIv5 give me informations

$ curl -H "Authorization: OAuth TOKEN" https://api.twitch.tv/kraken/
{"identified":true,"token":{"valid":true,"authorization":{"scopes":["channel:read:subscriptions","channel_subscriptions"],  (… i cut the json…)

The call on new API give me :

curl -H "Authorization: Bearer TOKEN" https://api.twitch.tv/helix/
{"error":"Not Found","status":404,"message":""}

i’ll use api v5 to fix my issue because new api is not working for me :frowning:

There is no API that can responsd at https://api.twitch.tv/helix/

Just talks about the headers for each API

Only on /kraken/ helix doesn’t have an equivalent as replaced by:

Validation (which was the /kraken/root endpoint originally) is handled via

Hi, just came here because I’m having the same issue this morning. It was working fine for me yesterday. I’m located in the US/California.

1 Like

This has been passed up the chain for some people at Twitch to investigate futher


Just closing the loop- the issue was identified and remedied, so you should be good to go now.

Please feel free to reply if your’e continuing to see issues.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.