Segault when attempting to host hello world app

Hey folks.

I’m running into an issue when attempting to host the hello world application (

When I attempt to clone the front end using the built in:
yarn extension-init

I get the following:

yarn run v1.7.0

$ node ./scripts/extension-init.js
Segmentation fault (core dumped)
error Command failed with exit code 139.

I run into this with and without passing parameters. I also get the same error when simply running the node command. I’m running node v8.10.0 on ubuntu 18.04. Yarn is version is v1.7.0 as stated above.

Thanks for the help!

  1. mkdir myProjec

  2. cd myProject

  3. git clone

  4. cd extensions-hello-world

  5. make sure you are in the directory that contains the json package

  6. npm install

  7. npm run cert

  8. npm start: init backend

  9. open another terminal (ctrl+alt+t)

  10. npm run frontend

I believe it to be this, try

can you paste the command you ran when this happened? i’ve only been able to kind of repro it, i ran into this if i had an existing directory and tried to clone extension-init into that already existing directory.

the command is ran was yarn extension-init -a twitchdev -r extensions-hello-world -l hello

I didn’t get a segfault when I ran npm run frontend, so thank you for that. I was unable, however, to map the hello world app to my running developer instance. But that’s a different issue I’m sure I’ve caused.

Thanks for your help!

Edit: It looks like launching it through the method @AlbericoD describes disregards use of the dev-rig. While this works, I definitely would rather use the dev-rig as I’m a lazy, lazy man. ;D

@davethecust The exact scenario was something like this:

Clone the developer rig
Went through setup
Executed from inside the dev-rig directory: yarn extension-init -a <github-username> -r -l hello

yarn run v1.7.0
$ node ./scripts/extensions-init.js -a <github-username> -r -l hello-world
Segmentation fault (core dumped)
error Command failed with exit code 139
info Visit for documentation about this command.

I hope this is helpful, and appreciate your time.

is not the same structure but is similar to this link

Yeah so run this yarn extension-init -a twitchdev -r extensions-hello-world -l hello or replace the directory you want to clone to. The GitHub account should be twitchdev and the repo should be extensions-hello-world

1 Like

Thanks @davethecust, looks like I misunderstood the documentation on github account. I thought it meant my personal one.

After changing how I was using it, I was still running into the segfault. So I ended up deleted the project repo, and reinstalling yarn. Now it’s working without a hitch. I appreciate your time guys. Sorry about that.