Sending/Receiving messages to/from other channels?

Hi, I’m testing IRC functionality on Twitch.

I made two accounts, let’s call them channels A and B.

Sending/receiving messages works fine when doing A ↔ A communication.

But, A ↔ B doesn’t work.
I am able to join B with A,
but when I send PRIVMSG (A → B), I simply don’t get any response (A ← B).

Is this intended? Or am I doing something wrong?

I tried:

  • all 4 IPs (websocket and IRC, with and without SSL);
  • made sure that every message i send has \r\n at the end.

im using python’s socket library

Check for any NOTICE or USERNOTICE indicating a problem or error

A common issue is the destination channel has requirements (such as follow needed or security verification) that the account doesn’t have and you didn’t log that

weird, i didnt change anything on any of the channels but now it works. i dunno anymore what is going on, feels like irc randomly stops working with other channels sometimes.

Make sure you have it sent to record NOTICE/USERNOTICE so you can track any errors.

I wonder if you tried to self repeat and hit the “no repeat in 30 seconds” which will have raise a NOTICE to log

well, it just stopped working again.

hmm, i print all messages that i receive from the socket, i dont see anything about NOTICE or USERNOTICE. i dont get any response at all.

does no repeat in 30 seconds ban you from using IRC for a long time or something? coz i did send “hello” a couple times in a row lol.

No

if you are not a vip or better you cannot repeat the same message in 30 seconds. You get a NOTICE error

If you exceed the message sending rate limits then you can get a “global” that kicks you out from everywhere for 30 minutes.

Kinda seems like the destination channel timed you out

but both channels are mine. im testing. im not timing myself out. or does timeout happen automatically?

A timeout or ban is an action performed by a moderator on the channel. (which sure could be another chatbot) and mods can’t timeout mods.

It’s not automatic.

Sounds like you might be exceeding send limits and getting the 30 minute global then

i was sending like max 1-2 messages per minute. maybe documentation limits are out of date and things have become more strict?

No the documentation on rate limits for message sending is accurate.

And 1-2 messages a minute is way below any limits.

I have nothing obvious left to suggest