Twitch API Stream response never showing anything on "streams" object

I am having this issue where the stream object is always empty, for example:



Even if I am streaming, it is showing null, I’ve tried other users and friends and their streams work fine so I am wondering if I have to set something up in my account to make it work?

Might not be related but I had an “Access Code” enabled when it was removed from settings, could this be affecting it?

it works , for example:


{"_links":{"self":"","channel":""},"stream":{"_id":7666959024,"game":"StarCraft II: Heart of the Swarm","viewers":16144,"preview":{"small":"","medium":"","large":"","template":"{width}x{height}.jpg"},"_links":{"self":""},"channel":{"mature":null,"abuse_reported":null,"status":"KingkOng vs. Happy - Losers Match - Group B - IEM Singapore","display_name":"esltv_sc2","game":"StarCraft II: Heart of the Swarm","delay":0,"_id":30220059,"name":"esltv_sc2","created_at":"2012-05-02T09:59:20Z","updated_at":"2013-11-29T10:24:38Z","logo":"","banner":null,"video_banner":"","background":"","profile_banner":"","profile_banner_background_color":null,"url":"","views":29209391,"_links":{"self":"","follows":"","commercial":"","stream_key":"","chat":"","features":"","subscriptions":"","editors":"","teams":"","videos":""}}}}

I am streaming right this moment and the “streams” for my account is null. I have seen it work on others and tested on a few accounts, all fine, except my own.

Here is a screenshot:

Streaming right now, says


I think something is really incorrect in my accounts permissions, even the “profile” says I am offline, even though I am streaming live,

I replied to you on Twitter. I think its related to your channel being marked as hidden. I’ll see if I can get a staff member to take a look at it today.

Thank you very much George!

To follow up, I made a new account completely and it works fine there, instantly showing live state on profile and the stream object returned. Maybe my vekien account broken!

I have found another user (A friend) experiencing the same issue:


Streaming at this moment:

Mine is still broken, I had to make a completely new account “viionxiv” and that works flawlessly. Seems some accounts just do not have the correct permissions or something.

I’m afraid I’ll have to leave this for Staff to answer. I did hear about another user experiencing the same issue and switching ingest servers resolved it.

I’m experiencing the same issue. A number of users that I’ve tried simply never show up as streaming! For example: - yet by viewing his profile I can view the live stream.

I’ve even tried variations on the username in case it was case sensitive, but nothing works. I’ve also verified that Prevent Embedding is unchecked.