Unable To Mute Embeds In Firefox or Edge

When using the basic Twitch embed code in Firefox or Edge, autoplay works fine, but the stream always starts with the volume on, which is extremely annoying for our website visitors especially when a pre-roll ad starts.

Here is the current embed code that is not working (I had to remove the brackets to keep discourse from hiding the code):

iframe src=“https://player.twitch.tv/?channel=“channel name”” frameborder=“0” allowfullscreen=“true” scrolling=“no” width=“640” height=“480” autoplay=“true” muted=“true”></iframe

The stream DOES start muted in Chrome fine on all devices. Firefox and Edge, and possibly other browsers do not respect the muted=“true” option.

I already reached out to Twitch partner support, but they just told me to contact help here.

Am I missing something, here? Is this code out of date? Any help would be very much appreciated!



You’re my hero dude, thank you so much! I’ve been ripping my hair out over this for months. Did I miss something in the official documents on embedding?

No idea. Thats why I linked to the docs for reference!

1 Like

Well anyways, thank you again for the quick reply and have an awesome day!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.