Users endpoint returns no result for certain user ids

Hi everyone,

Yesterday I tried to fetch my followers using the new Helix API.
It returned 182 follows. The correct amount. When I tried to translate them to full user data with the /users endpoint 2 of them were always left out of the response. The API just leaves them out, but returns a status of 200.

This is frustrating because it means the response of the API can’t be trusted. Since I wasn’t able to find out the username using the ID there was no way for me to check the profile of the follower.

I repeated this for other streamers too. One of them had 63 followers, but only 17 followers were actually returned in the /users response. I’m baffled.

Did anyone here have similar issues in the past few days?

Best regards,


1 Like

Could you tell me the IDs so I can look into it a bit more?

Banned, suspended, disabled, or otherwise unavailable users still show up in Helix’s followers list (and should these users ever become active, they’ll keep who they are following). Kraken on the other hand which displays a user object in the results, rather than just an ID, will just not have any result at all for those users, and you can even find out exactly what position in the list of followers that these ‘holes’ occur.

Most user endpoints that try to retrieve such a user just returns an empty array, which is why you’re not getting any data back. For the ID’s that you’re having trouble with, try this endpoint:<Channel ID>

If they are indeed banned/suspended/disabled/whatever you’ll get the response {"error":"Unprocessable Entity","status":422,"message":"Channel ... is unavailable"} which will explain why you can’t get a username from the ID, as it’s impossible to retrieve that user object (at least for 3rd party devs as far as I’m aware) and why Helix will not include them in the array when attempting to look them up…

1 Like


Here are a couple of them from another random streamer I tested:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.