Webhook Not Being Created Despite 202 Status

I am getting a 202 with my request as (in a Node.js environment) follows:
    let result = await got(“https://api.twitch.tv/helix/webhooks/hub”, {

        method: ‘POST’,

        headers: {

            “Content-Type”: “application/json”,

            “Client-ID”: TWITCH_CLIENT_ID


        body: JSON.stringify({

            “hub.callback”: ${APP_URL}/twitch_webhook/,

            “hub.mode”: “subscribe”,

            “hub.topic”: https://api.twitch.tv/helix/streams?user_id=${user_info.id},

            “hub.lease_seconds”: 864000


    }).catch(e=>{if(e) throw(e)})
though, after this 202 comes in I do not receive a GET request at my ${APP}/twitch_webhook/ URL. This has worked previously but does not work anymore. My only thought is the IP pointed to by my APP URL has changed, and perhaps Twitch has the wrong one cached?

Only if you changed your DNS, which can take up to 24 hours (or more) to propagate across the entire internet

Someone in the Discord had this issue, turns out they had Firewall blocked Amazon AWS.


  • check your GET handler is working, and web accessible
  • check that you haven’t done anything weird with Firewalls
  • check your SSL cert is still good and valid

Things are fine with my hook handler, so it’s definitely something yourside

Yeah my DNS did change within 24 hours ago, I’ll wait and see if that fixes it.

Even when using the actual IP address it still doesn’t get a get request on the GET, though my SSL cert still seems valid, at least to my browser. Firewalls haven’t changed.

And you’ve tested your endpoint yourself? eg, sending your own GET request to the callback and ensuring it responds with the value of the hub.challenge param.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.