401 error when trying to create new Twitch Developer Rig project


I am trying to create a new extension in Twitch Developer Rig. However, I cannot get past the Step 1 of “Create New Project”; When I click the “next” button, nothing happens. Upon opening up the developer tools, I found out that I receive a 401 from the auth endpoint (GET api.twitch.tv/{...}/secret) every time I try to proceed to the next step.

The whole response is:

  error: "Unauthorized"
  message: "Error (401): Authorization refused"
  status: 401

Image of the Rig window with the error:

Does anyone know what may be causing this issue? I have 2FA on and used it to log into Twitch Developer Rig already so I don’t think it’s a 2FA problem.




So, the project that I cannot completely create in Twitch Developer Rig, “exerciseTracker”, is showing up in my extension console at https://dev.twitch.tv/console/extensions. Can I do everything from that console that I could do with the Rig. I thought the only way to create a video overlay component was through Twitch Developer Rig.

Is that not true? I am still receiving that error on Step 1 in the rig but if I can get around the issue by creating everything in https://dev.twitch.tv/console/extensions, then I guess I’m fine. Any help is appreciated. Thanks.

Another update:


I tried to just delete the extension and start again but I am receiving an error message saying that I do not have permission. This is through Twitch Developers. I created this extension yesterday so I am not sure why I am unable to delete it.


1 Like

I’m having the same issue as you. Did you ever find a way around it?

I was able to get to step 2 by going into Console and selecting the extension type. I guess the dev rig is not setting this properly?

After selecting all options on step 2 (folder, starting code), step 3 failed, supposedly it couldn’t find npm, even though it’s definitely there. This is in the console:

Error: npm failed with exit code 127: /bin/sh: npm: command not found

(Can’t post two images as new user, otherwise I’d put a screenshot)

You need to install NPM and/or Node

And NPM needs to be in a usable $PATH

People tend to have issues if they have installed Node/NPM via NVM

So you make need to configure an Alias.

Or don’t use the Rig to spawn the example code

Your npm error can be because your npm isn’t installed correctly or you are using nvm for example.
The rig will only look at the basic npm install path (see Barry’s answer for more detailed information)

About deleting an extension, there is a known bug where you can’t delete an extension that doesn’t have a version in it. Create a version on the dev site, then delete the extension

It looks like you are using a mac, make sure you have the latest version 1.1.4. before the 1.1 version the auto update didn’t worked properly. Since then, there was a new video component design that was published. Preventing the use of the old video component design.
The rig 1.0.3 still ask for the old video component design, resulting in an error

Thanks for the help guys.

First of all, I downloaded directly from this page, assuming it would be the latest version, but no, it’s version 1.0.3.
EDIT: for others wondering, I found version 1.1.4 here.

Looks like NVM is initialised in .bash_profile, which only runs on login shells, which would explain dev rig not seeing npm. I’ll either have to move it to .bashrc or as you say, don’t use dev rig to spawn the code.