Asset Upload Unexpected Error

Anyone seen an issue of where uploading assets shows a green button, but then shows an error. The upload is never reflected in the console and there are no new errors in the browser’s developer consoles.

usual suspects to try and check

  • check your zip file isn’t too big
  • check your zip file contains only the relevant static HTML/JS/CSS/any images you need for your extension
  • logout and back into the dev console
  • check this version is in local test

I’m using the React boilerplate code with some of my own JS files. I’ve tried removing my custom files, but the same result. What is the size limit? It would help if they returned an informative error message.

So you ran npm dist (or whatever the complie command is)

Zipped the resultant contents of the dist folder (if it ouputs to there)

And uploaeded those contents?

for sure

Not sure, since it’s not documented, most extensions shouldn’t hit it unless they have a tonne of unneeded files or many big images.

But when people get errors we note it in case OP goes “oh I built the zip wrong”

It’s npm run build and zipping the contents of the dist directory. That fixed it. Thanks.