Commercial failure

Hello guys,

since 2 days i always get “(422) Unprocessable Entity.” after sending a commercial request by API. Someone else with this issue?

Some more Informations:

Online/Offline: Both not workin. If im online or offline ... both the same error.
Request URL: https://api.twitch.tv/kraken/channels/zaflu/commercial
API Version: v2 and v3 both the same
Error: "(422) Unprocessable Entity."
Twitch Dashboard: Ads workin fine for me

.

API Documentation says:

422 Unprocessable Entity if commercial length not allowed.

I think you’re missing the length parameter (see docs)

No the length should be ok.

Haven’t changed the ad stuff for 4 Month without any issues for now :slight_smile:

I’ve also seen a big increase in failed commercials. Haven’t had the time to look into it yet though.

I’m getting the same error and haven’t changed anything either, so something must have changed on Twitch’s side. Maybe I’m doing something wrong, but it definately worked before.

still broken for me :frowning:

We now only allow partners to run commercials when they are online. If you try to trigger a commercial when offline, you’ll get this error.

2 Likes

Ok but im Partner and i was online (6.5hours) and couldnt play ads by API requests. Only twitch dashboard ads …

Yeah I dunno if there’s a caching error or whatever on Twitch’s side, but I’m getting lots of failed attempted commercials that should not be failing (they are well within the requirements for running one)

1 Like

Ok today was fine with API ads.