Developer Rig - Failed to compile error

Sorry to be a bother here, I did a search of the forums and didn’t find the error I’m getting. I downloaded the developer rig, and installed all dependencies including but not limited to: Yarn, Node, Python (already had), and added and twitchtv to hosts file.

I also updated everything including some of the dependencies after running npm install, npm update, npm install react, YARN, yarn update… you know… all the essentials? I also deleted and started over a few times once from GitHub itself on the developer rig, and second straight from Twitch and also REPEATING all steps.


Okay. Now here we are. Same error. I also googled the error… to some-what close results? But they seem a tad over my capabilities. BUT let me tell you my error to see if maybe someone has already encountered and fixed and maybe? someone is also stuck on my very same problem WHO also did the onslaught of install, delete, install, google, forums, and talkie typie?

Anyway the suspense has been killing you:

Failed to compile.

[tsl] ERROR in C:\GitHub\devrig\src\user-dropdown\containe
TS2305: Module ‘“C:/GitHub/devrig/node_modules/@type
s/react-redux/index”’ has no exported member ‘Dispatch’.

Ugh! Let me add also, you can see - when the page starts to load after doing:

yarn start -l manifest.json

(I should have told you I was trying to run local mode, ugh)

You can see the page load for a very brief moment and then the error comes up.
I can actually run the host server without a problem. It’s just there’s something stopping the page from loading. I looked into console but… it pretty much has that exact same error. Any ideas?

Rather than doing npm install to get all of the modules, use yarn install. That fixed my issue when I was getting that error you’re getting.

I tried that on the first go around. I also - just tried it now to no avail.

Should I delete and start again? Because that would suck.

You can try deleting the node_modules folder and then running yarn start, but if that doesn’t work I’d suggest starting from scratch and not run commands that would put your rig folder in a state where we can’t really help.

I see your point.

I will start again.

Well… you were absolutely right. It was all self sabotage.

So the lesson here folks is don’t go all willie nillie and off the reservation. Follow the docs.

1 Like