Request for creating an organization got rejected, was told to go here


I am currently working at a game for a game studio, and we are going to use Twitch Drops. I tried to set up an organization through Twitch, but it was rejected, and I was told to post it here and come in touch with a mod.

Any help is taken with gratitude

Hello @pineleaftech,

What was the organization name you attempted to register with? Additionally, did your email match the company domain?


The organization name is the name of my game studio, Pineleaf Studio.
Yes, my mail matched the domain, which is

It looks like there were a few duplicate requests, but your company does have an organization that is approved- please check with your coworkers to see if anyone got an acceptance notice to get you added.

Thats good.

Do you have the possibility to tell me which user that managed to register the organization? I was the only one that tried to create it, but had to try multiple times because I never recevied confirmation.

If you login using the official account, it should have access - give that a shot.


I might be confused as to which account is the official one. I have just made 2 accounts and tried to create the Organization. I didnt get any message regarding my first attempt of creating the organization, so I tried again. This time I got the rejection, which I now know is because the first attempt was successful.

I have logged in on both these account, and I see no trace of the organization being made.

Sorry I replied with a different user, its still me.

Hi- it should be the PineLeafStudio account.

This topic was automatically closed after 30 days. New replies are no longer allowed.