Response 200, but empty JSONs


Starting this afternoon, every request I make (I’ve tried from my Python script I’m working on, Postman, and just curl) returns fine on the Get Stream endpoint, but is empty. I’m a bit confused, as I thought this was go away or was a Twitch issue. Is anyone else having issues? If not, on a broad idea what could be causing issues for me?

I can provide any other details that may help. I’m using the Helix API, and have proper authorization.

Thank you.

As a minuimum with get streams you should get

    "data": []

So no JSON at all is odd

Sorry, poor wording on my end then. I do get

    "data": [],
    "pagination": []

It might be page instead of pagination, I don’t remember. I meant empty as in nothing in it even when I definitely know streams are occurring.

What params are you using to make the request? Is your request just, or are you also using user_id, user_login, game_id or language?

The response you’re getting suggests you’re specifying one of those params, and that there are no live streams that fit that criteria.

I’m using game_id (in this case for testing the ID for Among Us, since I knew it would have streams live) and first=100. I have tried without first, and the response JSON is still empty. I had also read in an old post that it might have to be in alphabetical order, so I did try that to no avail.

Can you confirm the full URL you are calling.

And the code you are using with secrets removed. returns the first 100 results for Among Us. If you’re not getting that you should check the raw request being sent to ensure everything is formatted correctly and that you’re not sending something in a param you don’t intend to (such as sending the game name instead of ID perhaps)

Absolutely! I’ll note that my other queries are working perfectly fine. My full query is:{game_id} where game_id should be the game’s ID.

Just checked, it was that I was passing in the streamer ID by accident. I apologize for taking your time, that sure was a stupid mistake. I had just recently changed the way I was handling the game ID, and had forgotten to change that part. Thank you both! I’m still a bit confused why it returned empty on the curl though.

s’all good :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.