Send Extension PubSub Message failed with 403 result

When I use python to build my own ebs server, refering to hello world demo, http request encountered 403 error return.
Http crul is:

Admin Removed Secrets


Use fiddler to view the header of the http request from twitch:

You bearer is incorrectly formatted.

Did you base64 decode your secret before use?

You seem to have left you bearer visible in the first image, this is bad practice, generated bearers should be treated as secret and not posted to forums

Yes, this problem has solved,thanks.
But,i have a new question:
when i make the http request:<client_id>/live_activated_channels,i receive the response:{“error”:“Not Found”,“status”:404,“message”:“Error (404): The record was not found”}.
Is this api has discarded?

This API endpoint only works for a released extension, not one in testing

In the development phase, I want to implement a function that Pubsub data to the currently active channel ids, how to achieve these active channel ids?

If you want to send to all “active” channels just send globally as documented:

That means one API request instead of having to do 50 (if 50 channels were live)

There is a problem that the message send to diffferent channel is different. Because in my extensions,the broadcaster of channel has different user infomation in game.

Then in the development phase the only way to know whom has your extension active is to assume that everyone in your whitelist has the extension installed.

An alternative is to read onAuthorised and post back to your EBS, but that only dings on a viewer load.

In dev, it’s best to just assume everyone in your test whitelist is active. (Since that will only be a short list anyway

In the test phase, i want to set whitelist, so our tester can install the extension. ,But i dont find the entrance in my Extensions Dashboard. Can you tell me?

  • Extensions Dashboard
  • Manage an Extension
  • Versions
  • Manage a Version
  • Access Settings

Testing list is the bottom section

i have set access Settings,but our tester don’t find the extension in Extensions DIscovery

You have only populated the broadcaster whitelist.

You have not added that user as a Tester.

yes,and it works now.Thanks very much