[Developer Rig] User not authorized to see expired products under specified Domain

First of all, thank you for creating the developer rig, I think it was an amazing tool and it helped me from the beginning in the development of my extension.

My extension is ready for review, but I would really like to enable the use of bits, so I started the search process to integrate, even there with no problems.

The problem:

I have not updated the tool for some time, I did the git pull, and there were some new things that I could not understand and work correctly, I particularly need to make the bit part work (it’s my biggest interest at the moment)

commands used to update:

cd twitch / developer-rig && git pulll && yarn, ok.

then I initialized normal with the variables followed by yarn start, ok.

the rig starts without a problem on port 3000 as it always worked, okay.

The test of the resources is by the hosted test (it is in the process of review).

the rig correctly loads the viewer, live config and config, ok.

now, when I try to add a bit product, it is registered correctly, however, the SKU and product name does not appear in the configuration links.
an error with red header on top also occurs. and configurate bits : User not authorized to see expired products under specified Domain.

I searched the github issues to see if it was any known error or configuration, I also tried to read the documentation several times

I really need to use developer rig to correctly test the bits and iterations of users, does anyone know what I’m doing wrong?
I took some pictures to illustrate better:

hmm this definitely looks like an issue with your authorization if you are getting that error message in the last image.

That occurs when your extension does not belong to the user ID you’ve passed in through the environment variables. To manage bits products you have to sign in, so I’d recommend unsetting the EXT_OWNER_NAME environment variable when you run the rig and try again. Hopefully that helps!

The problem with saving the product was resolved by clearing the localStorage and logging in again, the red stripe problem persists, but can be circumvented by updating the page. the only thing that still does not happen is the saving of the manifesto in the configuration with the SKU products

sorry for the confusion! that is actually the correct behavior. the sku field in the manifest is actually related to In-Extension Purchases which is in limited preview - https://blog.twitch.tv/introducing-in-extension-purchases-now-in-limited-preview-116a0c30017.

1 Like

Got it, so I will not be able to use bits in my extension for now? or I have to do something else, thanks for the answer, I even tried to get the product catalog by function:


In-Extension purchases and bits in extensions are actually two different things. You are free to use bits in extensions while In-Extension purchases is still closed beta.