Error with EvenSub

I’m doing a EventSub on my express server with a domain with protocol https on port 443 all works fine except that the request with the challenge doesn’t arrive to the server.

The domain is from IONOS and is configured to point with a A record to the IP of the server.
The domain is “https://lint.es” and works fine doing a manually post but the Twitch verification doesn’t reaches the server. Why?

I used SSL Labs to test your SSL configuration

https://www.ssllabs.com/ssltest/analyze.html?d=lint.es&hideResults=on

it reports you have chain issues as the chain is incomplete
So you appear to have a SSL Configuration issue

as a result Twitch doesn’t “trust” the connection, some browsers might but not everything will due to the incompleteness

1 Like

I have a certification issued by CertBot and I’m using it like this:

const https = require('https');

const http = express()

http.all('*', (req, res) => {
  return res.redirect('https://' + req.headers['host'] + req.url)
})
http.listen(80)

let options = {
  key: fs.readFileSync(
    `C:/Certbot/live/lint.es/privkey.pem`
  ),
  cert: fs.readFileSync(
    `C:/Certbot/live/lint.es/cert.pem`
  ),
}

https.createServer(options, app).listen(443, () => {
  console.log('App listen on', 443)
})

Most people generlaly make nginx handle SSL and leave SSL stuff out of node.

You did a key and a cert but but no chain for node iirc the solve for this, since it doesn’t accept a third file

is to copy everything from the chain.pem into cert.pem after the cert that is in cert.pem

1 Like

It worked switching the “cert.pem” to “fullchain.pem” thx anyways for the web

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.