Hello-World Extension - Dev Rig - Color doesn't update

Hey all. I recently set up the dev rig and am running the hello world extension in local mode on the dev-rig as detailed with the documentation.
I have the frontend hosted with the dev rig, and the backend running (3 consoles). I have a setup on Windows and Ubuntu, and am getting the same problem on each.

When I run everything, the extension seems fine and if I click “Yes, I would” on either the broadcaster or a logging-in Viewer display it will change the color on those displays. The problem is that it does not update other displays, if I refresh the localhost and reload then the 2 displays will both switch to the correct color, but they don’t update off the broadcast.

Looking at the backend console indicates that the broadcast message returns a 204 from the pubsub. I am still new to utilizing API calls/javascript/pretty much everything extensions are built upon, so not entirely sure if this is the actual intended functionality, but I believe that the broadcast is supposed to actually be sent to all the viewers and they would listen and update their own color, this just isn’t occurring.

Would anyone have any further insight to this? I am glad to provide anything additional as needed

Ubuntu is not currently supported. On Windows, how did you configure and start the Developer Rig? Also, please provide screen shots of the three command prompts running the front-end, back-end, and Developer Rig.

Yeah, I couldn’t find anything still supported for ubuntu, but figured I’d give it a shot utilizing some older repos and what not as I can’t get access to a mac machine. Wasn’t expecting much with it, just was more of a “hey, maybe this might work”.

When I was going back through to write up exact configuration I think I was able to identify what is probably causing the error, I’m just not entirely sure what is going wrong.
Will include everything though just in case it isn’t that.

I setup everything as detailed in the README of the developer-rig for Windows and Local Mode.

I ran install/configure cmds, Installed the certs that were created insides of developer-rig/ssl.

Initially I ran the “run.cmd”, but it was not running correctly(While doing this configuration check, I actually learned why this was failing and will detail it after, as I believe this is the current problem), so instead I did everything manually. Setting up the manifest as panel.json as documented. Then ran the 3 command prompts (asset hosting, hello-world backend, and running developer rig). These are the 3 command prompts when the error occurs.

Broadcaster updates upon click, viewer color does not update
Asset Hosting

Now where I think the problem is arising, I’m just not sure why.
It seems that the run.cmd is failing because the configuration is not actually setting up correctly, if I manually run ‘check-install.cmd’ it has an error level of 0, which is good. But upon running ‘check-make-cert.cmd’ it returns with an error level of 2, all three certs are created so I believe this error is upon checking if the cert is actually installed for “Twitch Developer Rig CA” on the local machine, a run through powershell of the ‘{Get-ChildItem -Path Cert:\LocalMachine\Root}" | FIND “Twitch Developer Rig CA”’ Does seem to confirm that(There is nothing there), but checking mmc and looking at “Trusted Root Certification Authorities/Certs” I am able to see the Twitch Developer Rig CA cert there. I believe this would indicate that the cert is indeed installed correctly, but it doesn’t seem to be found when checking through powershell, I am new to utilizing certs (mostly do offline applications), so I am not entirely sure what to expect here otherwise or what to be looking for. But I believe that the cert problem is causing the rest to function incorrectly.

Thanks for any help able to be provided.

What browser are you using? Also please verify visiting https://localhost.rig.twitch.tv:3003/ gives you the word “live” in your browser.