Issues setting up Extensions Boilerplate project

I am trying to setup the extensions boilerplate project from github found here:

When I run the “docker-compose up --build” command, I get errors saying “testing.key” doesn’t exist. I’m new to Docker so not sure where to look next.

Can someone please help me get this setup? Very eager to start developing extensions but don’t know where to get started :slight_smile:

did you actually go through the process of creating your key & certificate as described here:

Thanks for your reply. Yes, I executed the “./” command and it generated a file in the certs directory but I’m not sure what I need to do with it beyond that.

it should generate 2 files:

  1. testing.crt
  2. testing.key

If you’re on Windows and don’t have bash at your disposal, try this batch file I used including the modified config:


Thank you! When I first tried playing with the boilerplate, I couldn’t generate the key/cert for the life of me. :sweat_smile:

1 Like

After seeing the comment from @mBeierl, I searched “bash on windows” and came across the following article showing how to setup bash on a Windows machine, Windows Subsystem for Linux.

I was able to generate the “testing.key” and “testing.crt” file and can successfully start the boilerplate extension with “docker-compose up --build” command now and browse to viewer.html page by going to https://localhost:8080/viewer.html

Wanted to post this in case anyone else is having the same trouble getting started. :slight_smile:


hey mrpurp, I’ve tried setting up the boilerplate using the Windows subsystem for Linux and bash. I’ve managed to generate the certs (needed to use dos2unix on, for those wondering) but am unable to get “docker-compose up --build” with an “./ no such file or directory” error.

Was that something you dealt with as well?

1 Like

I’m having the same issue, not really sure how to fix…

The batch file wont generate any files for me. No error messages or anything. I have Docker installed, any ideas?

If you don’t want to bother with certs, you could always use ngrok for dev purposes. That’s what I did when making my extension and it worked perfectly. Not too hard to setup if you need help.

1 Like

Thank you so much @mBeierl for the link to that new openssl req command and openssl.cnf file. I am running this on Windows 10 and my solution to this was to replace the openssl req command that’s given in the boilerplate example with the new one that @mBeierl provided. I was then getting the same ‘Subject does not start with ‘/’’ error that is described here on Stack Overflow (with solution).

1 Like