Need user_read scope locally (401 Unauthorized)

Awhile back, I put a lot of effort into a script that would allow me to pull the streams I follow from the Twitch API. It turned out to be extremely useful to me. So much that ended up making a wall fixture out of a Raspberry Pi (development board) to watch the streams.
It was all coming together so smoothly. Then, I took a bit of a break, and tried the script only to get a 401 Unauthorized response. After some research, I found the “scope” I need to access now requires “user_read.” Where previous I had just chat_login or null.

Docs say I need user_read:
GET /streams/followed
Returns a list of stream objects that the authenticated user is following.
Authenticated, required scope: user_read
Source: https://github. com/justintv/Twitch-API/blob/master/v3_resources/

This is what I used previously:
curl -s -H “Accept: application/vnd.twitchtv.v3+json” -H “Authorization: OAuth ${o_auth}” \ -X GET

I can’t seem to figure out a way to do that request locally. I use this script for my own personal use. I don’t run a server (which is a resource consideration on a platform like an RPi). I noticed the client_ID sticky as well. Side note I tried: here)&scope=user_read. Didn’t work :stuck_out_tongue:

Can someone point me in the right direction that fits my use?
                 Thank you,

I use to create tokens with different scopes for requests that are not integrated into a web application.

1 Like

I wish I had stumbled across that site directory before. The link worked a treat.

Thank you very much George! :blush:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.