Twitch not working on Maxthon browser

Ok this started happening like 2 days ago . when i goto the twitch site the main page loads fine but when i click to veiw channels i follow it shows a black pace with the twitch logo on it . Im using maxthon browser its worked perfectly before … any other browser works fine

I also use Maxthon and have been experiencing the same issue. I can’t say that I have a fix, exactly - but I was able to circumvent the issue by updating my Maxthon browser to their current beta release build, which you may look into here:

Not a perfect solution, but the beta release does have some shiny new features at least. Being able to mute tabs is a godsend. Since it is a beta release it may have other bugs but I haven’t encountered anything.

Edit - forgot to mention, betterttv seems to not work with the beta release (for me anyway)…but you can at least view streams.
Edit2 - lol. I got bttv working again but it might have just been me. In case you do need help; I had to reinstall the script and then ctrl+f5 on twitch. If that isn’t clear enough or you need further help, let me know.

TY , that worked like a charm i love this browser, Ty again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.