getProducts() returning empty array

I am getting an empty array when I call window.Twitch.ext.bits.getProducts in my extension. This helper function had been working perfectly fine for me as recently as yesterday. I can still load my bits products inside the developer rig, but not when I interact with the extension on twitch.

The extension is in the ‘Hosted Test’ status.
All bits products are set to ‘In Development’ = Yes
I have tried settings the bits products ‘In Development’ status to No, but that didn’t change the getProducts response from being empty.
I tried adding a new product, but that had the same outcome of working on the dev rig but not on twitch.

Other helper functions such as authorization and configuration are working properly in both situations.

Does anyone have any ideas on what might be causing this issue?

Check the following

Bits enabled, in the console

Bits enabled on the extension on the channel

Failing that just completely reinstall the extension to the channel.

Hey Barry, thanks for the reply.

I had bits enabled in the console and the extension permissions already. I tried toggling them off then back on and also tried reinstalling the extension. Unfortunately that did not resolve the issue.

I also tried creating a new version of the extension and installed that, but that did not work.
Lastly, I had a friend who had been able to load the products array before (in both the config and dashboard extension versions) try it out again and that did not work either.

The twitch dev rig still correctly loads the products in both local hosted test state and twitch hosted test state.

The only thing I can think of that has changed is that I attempted to test the extension while streaming yesterday, since it is a video component extension. getProducts has not worked since that happened, but that may be a coincidence.

If you or anyone has any other ideas, I would love to hear them.

I replicated the problem

and based on additional feedback on a related issue in Discord.

Looks like somethings awry/changed since Friday. It’s been flagged internally!

1 Like

Thank you for doing that! Greatly appreciated.

I can confirm it is now working again for me.