Hosted test not working?

I don’t know if I am an idiot or what and I tend to miss documentation when learning something new because I just skim but no matter what I do can’t get my extensions to run on the Twitch website. I upload the files in a zip then I clip start hosted test and the extension/config on Twitch is blank. I have also tried hosting it myself although I am sure I am doing something wrong in this case because I don’t really understand the base URI thing. I have also left the panel viewer/config paths default I don’t really understand this either. I just want to know how to get something working whether it’s the Hello World example or my code but I can’t.

1 Like

Okay so there are a couple of things to note or if you can supply.

make sure you have the following in all your html files.

<script src=""></script>

When you create the zip file don’t include the root directory.

If those aren’t the issue maybe a good old F12 and inspect the load to see if there are any errors

1 Like

I still can’t seem to get it to work, I have even tried downloading the hello-world zip and uploading that and the extension is still blank.

Please check the chrome console (f12) or equivelent and check the network tab, and we can see what errors are occur. Specifically we are looking for non 200 error codes on resources.

Secondly then check the main errors under console of CSP and/or Javascript Errors.

I’m assuming you did this verbatim without a zip repack?

Do I look at the Chrome console from the Twitch page? I am still pretty new to net stuff I don’t know what to look for. I see this:
2panel.html:1 Failed to load resource: the server responded with a status of 404 ()
vendor-5182f7f13a7032c44bf7.js:45 Extension Warning (l904ik8qte34t406ny7tx2zhlpkgpj): Extension Helper Library Not Loaded
Also I tried downloading the .zip for the hello world and directly uploading that and I also tried taking all of the the files in the root folder out and zipping that.
I am probably missing something simple I just don’t know what

Sounds like you are running into this issue

It’s reporting that extension helper is not loaded which indicates:

<script src=""></script>

Is missing, it could be missing as the index/panel HTML was not loaded as it’s in a folder in the extensions directory instead of in the root. But you got a good hit on panel.html apparently

1 Failed to load resource: the server responded with a status of 404 ()

Did this file not get uploaded or was it renamed and not updated in the panel.html

These errors are from when I had the hello world example loaded. Everything else is default

Hello World as described here



I downloaded the rig, downloaded hello world

Zipped the contents and uploaded. Moved to hosted test. All fine.

I believe you are uploading the wrong files?