How to make extension public?

How to make extension public?

  1. Extension is released.
  2. No entries in “streamers whitelist” exist.

The note says:

Select streamer accounts (searchable by unique ID or username) that will be allowed to install the extension after release. If this is empty or missing, all broadcasters can use this extension.

And it actually empty. But it’s still not possible to install the extension for other users:

What is the problem?

1 Like


Also looks like you have a broken TwitchID in the streamer whitelist.

It should look like

Yeah looks like you have a “streamer” set in the whitelist.

But it has no avatar or name that can be displayed or an x to x it in your screenshot

So what can I do? I can’t delete it.

You’ll have to open a support ticket (or contact your dev partner manage if you have one)

And they should be able to help.

I have poked someone in the know, whom might be able to help. But timezones! Twitch isn’t in the office for a couple of hours.

You will need to clone and then release a new version. But clone for now and then we can look at fixing the new version.

Edit: Please open a support ticket and they’ll be able to help you!

1 Like

Just sent my support ticket. Thanks.

b.t.w. The situation in my dev console looks like this:

No cross button. Click does nothing.

Finally I fixed it by myself. This blank square was user with my user ID.

I debugged the page, found the method that was actually deleting the user from a list.
Method located in the script: at the line 3654.


I put breakpoint here, replaced value in variable e.userID with my username and this blank square disappeared. Simple as that.
I’m just curious what’s taking so long for the Twitch team to fix this simple bug?

@FlamesoFF - did you get help here? please open a ticket from here

@mauerbac I already opened it, but I don’t want to wait several months for response. That’s why I tried to fix this problem by myself (and I successfully solved it, btw.)

@FlamesoFF thanks for posting this resolution here! we’ve submitted a ticket to look into this bug to see if there’s anything we can do on our end to prevent this for other devs in the future.