Developer Rig - Seeing same view everywhere

Hey fellow Twitch enthusiasts,

I’ve begun developing a video component extension and am noticing that the developer rig shows the viewer html for broadcaster / logged in / out viewers.

Also the Broadcaster Config & Live Config tabs are empty. I have tried running the Hello World extension and a couple other example extensions, all the same.

I have verified the configuration (shown below) and they do match the directory structure. But again, every view is showing the ‘viewer/viewer.html’ doc. Is this supposed to be true for the “Extension Views” tab?
Are the Config tabs supposed to be empty?
Thanks in advance!
Let me know if I need to clarify anything.

"viewer_url": "",
"viewer_urls": {
    "component": "https://localhost:8080/viewer/viewer.html"
"views": {
  "config": {
    "viewerUrl": "https://localhost:8080/config/config.html"
  "liveConfig": {
    "viewerUrl": "https://localhost:8080/live_config/live_config.html"
  "component": {
    "aspectHeight": 4000,
    "aspectWidth": 3000,
    "size": 0,
    "viewerUrl": "https://localhost:8080/viewer/viewer.html",
    "zoom": true,
    "zoomPixels": 1024
"config_url": "https://localhost:8080/config/config.html",
"live_config_url": "https://localhost:8080/live_config/live_config.html",

Have you double checked that your frontend assets are being hosted at: https://localhost:8080/ (and that they are available)? Open a new tab on your browser and hit one of the URLs, and see if it loads.

I have. I tested the URLs exactly as they are in the configuration, each one displays and is unique.
Do you suppose this could have anything to do with SSL?
I believe when I first had went to one, it displayed the Chrome security warning…

The extensions view tab will show the viewer.html view (so many uses of the word view). The config and live_config (broadcaster config) should load config.html and live_config.html respectively. Is viewer.html rendering correctly?

Ok, understood - that makes more sense. Yes, the viewer/viewer.html renders perfectly.

Going go Broadcaster Config tab and Live Config tab display nothing.
There are no console errors and inspecting them shows nothing but an empty “wrapper” class div.

Navigating directly to https://localhost:8080/config/config.html and https://localhost:8080/live_config/live_config.html show the respective views.

I have these problems with the last git pull I made of the developer repository rig, I think I better report here

I made my first git pull / clone mid-last week. There have been two commits since - when did you start experiencing this? I noticed this from the get-go

I am with the last update, this env.local I created to get easier with yarn start

the two changes that went in last week were a typo fix and an addition of a gitattributes file that makes reviewing code easier - shouldn’t impact this.

i was unable to repro this.

some steps i can suggest in the meantime - either get chrome to trust your cert(we have a script for this on osx, or you can look up how to do it for other OSes), or manually visit each page to accept the chrome security warning for each page. i don’t know how you’re hosting your front end files, or what your directory structure looks like but it’s possible you may be not hosting those files if nothing shows up.


I have the same problem too, the configuration button in the rig shows the URL’s to the config and live_config pages are correct, and they load fine when I go to those URL’s directly, but in the rig the Broadcaster Config and Live Config tabs don’t load the pages (and no errors in the console relating to this).

Was able to repro this at work, but not my home machine, I’m pretty confused as to why but hopefully I can get a fix out asap!


That would be amazing. Appreciate your help!

should be fixed!

please be sure to pull the latest changes. and feel free to let me know if you run into any more weirdness.


Shoutout to @davethecust! That worked wonderfully! Thanks, man!